Mail archive
alpine-aports

Re: [alpine-aports] [PATCH] main/erlang: Update to 18.1

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Thu, 1 Oct 2015 17:54:49 +0200

On Thu, 1 Oct 2015 09:19:17 -0300
Marlus Saraiva <marlus.saraiva_at_gmail.com> wrote:

> 2015-09-30 9:40 GMT-03:00 Natanael Copa <ncopa_at_alpinelinux.org>:
>
> > On Tue, 29 Sep 2015 00:51:43 +0000
> > Marlus Saraiva <marlus.saraiva_at_gmail.com> wrote:
> >
> > > ---
> > > .../0006-Do-not-install-erlang-sources.patch | 531
> > +++++++++++++++------
> > > main/erlang/APKBUILD | 26 +-
> > > 2 files changed, 382 insertions(+), 175 deletions(-)
... ^
> > hipe/hipe_x86_signal.c:233:15: note: each undeclared identifier is
> > reported only once for each function it appears in
> > #define _NSIG NSIG
> > ^
> > hipe/hipe_x86_signal.c:341:21: note: in expansion of macro '_NSIG'
> > for (i = 1; i < _NSIG; ++i) {
> > ^
> > x86_64-alpine-linux-musl/Makefile:956: recipe for target
> > 'obj/x86_64-alpine-linux-musl/opt/smp/hipe_x86_signal.o' failed
> >
> >
> This happened because you had m4 installed in your environment and I
> didn't. When m4 is found, hipe is enabled by default. If hipe is enabled,
> we need to apply an additional patch. I already have the patch working fine
> and will submit it among the other changes. My question is: should I add m4
> to "makedepends" or should I assume it's already installed in your
> environment before you build the packages?

it has been pushed already.

in this case we should probably have a --disable-hipe or
--disable-m4 or similar so it builds even with m4 installed.
Alternatively we could also add makedepends="!m4 ..." with a comment
explaining why m4 cannot be installed on build box.


thanks!

-nc


---
Unsubscribe:  alpine-aports+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-aports+help_at_lists.alpinelinux.org
---
Received on Thu Oct 01 2015 - 17:54:49 GMT