Mail archive
alpine-aports

Re: [alpine-aports] Broken packages

From: Isaac Dunham <ibid.ag_at_gmail.com>
Date: Sun, 8 Nov 2015 14:53:08 -0800

On Sun, Nov 08, 2015 at 06:03:34PM +0000, IT Developer wrote:
> On 08/11/15 17:27, Valery Kartel wrote:
> > Current version libsodium library is so.17
> > There is a list of broken packages, that linked against old version of
> > libsodium.so.13
> > testing/dnscrypt-prosy
> > testing/fastd
> > testing/quicktun
> > testing/tinyssh
>
> I use tinyssh / dnscrypt-proxy - they still work for me but will be
> broken for new installs.

> > As I see, tinyssh needs 'tcpserver' from testing/ucspi-tcp to start
> > service. But the package testing/ucspi-tcp is not compiled and exists
> > only in git. And tinnyssh's APKBUILD have no ucspi-tcp in depends.
> >
> ucspi-tcp (for tinyssh) is still installable.

apk search only shows ucspi-tcp6.

However, I'd like to comment that anything that can be run via ucspi-tcp
*can* be run via inetd (or with the correct invocation of a suitable
'netcat' version).
 
> Do I need to manually request rebuilds of dependent packages when I
> update libsodium or should rebuilds occur automatically ?


Rebuilds are not automatic; a library that changes ABI should be
followed by a patch series to rebuild each dependency.

HTH,
Isaac Dunham


---
Unsubscribe:  alpine-aports+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-aports+help_at_lists.alpinelinux.org
---
Received on Sun Nov 08 2015 - 14:53:08 GMT