Mail archive
alpine-aports

Re: [alpine-aports] [PATCH] main/alpine-conf: Change /etc/lbu/lbu.conf permissions to 644. Filesystems creation fixes and description added in setup-disk script.

From: Valery Kartel <valery.kartel_at_gmail.com>
Date: Tue, 15 Dec 2015 14:07:23 +0200

I made a second test:
Firstly I upgrade previously installed 3.2.3 to edge. Then I connect second
drive '/dev/vdb' and apply setup-disk to it.
All sems fine but vm does not boot from second drive. It stuck on SYSLINUX
info-line.

I compare both /dev/vda1 and /dev/vdb1 partitions. They are the same but
from /dev/vda1 it boots and from /dev/vdb1 don't.

:(


2015-12-15 12:21 GMT+02:00 Natanael Copa <ncopa_at_alpinelinux.org>:

> On Fri, 11 Dec 2015 13:35:46 +0200
> Valery Kartel <valery.kartel_at_gmail.com> wrote:
>
>
> > _at__at_ -0,0 +1,71 @@
> > +--- old/setup-disk.in
> > ++++ new/setup-disk.in
> ...
>
> > +_at__at_ -917,6 +920,12 @@
> > + -s Use SWAPSIZE MB instead of autodetecting swap size (Use 0 to
> disable swap)
> > + -v Be more verbose about what is happening
> > +
> > ++If BOOTFS, ROOTFS, VARFS are specified, then format a partition with
> specified
> > ++filesystem. If not specified, the default filesystem is ext4.
> > ++Supported filesystems for
> > ++ boot: ext2, ext3, ext4, btrfs
>
> I actually tested this. It does not boot if BOOTFS=btrfs.
>
> -nc
>



---
Unsubscribe:  alpine-aports+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-aports+help_at_lists.alpinelinux.org
---
Received on Tue Dec 15 2015 - 14:07:23 GMT