Re: [alpine-aports] [PATCH] testing/libgflags: new aport
On Sat, 9 Jan 2016 12:23:33 -0500
David Huffman <storedbox_at_outlook.com> wrote:
> Since it only provides a library and not an application, I figured it
> would be preferable for organization purposes. Was I wrong?
> (Sorry about you getting this twice, my email client apparently isn’t
> a fan of replying to mailing lists without some coercion.) Warm
Yes, this is the standard practice. library-only stuff is usually
prefixed with lib.
The aport looks good with the exception that it installs:
Either delete it or make it a subpkg with install_if for bash. See tmux
or grep "bash-completion" in the main/*/APKBUILD for examples.
Please resend that fixed, and I'm happy to apply it.
> David Huffman
> From: Sören Tempel
> Sent: Saturday, January 9, 2016 10:29 AM
> To: alpine-aports_at_lists.alpinelinux.org
> Cc: storedbox_at_outlook.com
> Subject: Re: [alpine-aports] [PATCH] testing/libgflags: new aport
> On 09.01.16, David Huffman wrote:
> > +# Contributor: David Huffman <storedbox_at_outlook.com>
> > +# Maintainer: David Huffman <storedbox_at_outlook.com>
> > +pkgname=libgflags
> > +pkgver=2.1.2
> > +_srcname=gflags-$pkgver
> Is there any reason why you called the package libgflags instead of
> simply naming it gflags? Than you wouldn't need the _srcname
Received on Tue Jan 19 2016 - 14:35:48 GMT