Mail archive
alpine-aports

[alpine-aports] [PATCH] testing/mongodb: use wiredtiger from system instead of internal

From: Marc Vertes <marc.vertes_at_ugrid.net>
Date: Thu, 14 Apr 2016 09:45:47 +0200

This requires wiretiger-2.8.0. Previous 2.7.0 was causing problems
when dropping collections which are now fixed in 2.8.0.
---
 testing/mongodb/APKBUILD | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/testing/mongodb/APKBUILD b/testing/mongodb/APKBUILD
index 39e03b9..236b975 100644
--- a/testing/mongodb/APKBUILD
+++ b/testing/mongodb/APKBUILD
_at_@ -2,14 +2,14 @@
 # Contributor: Marc Vertes <marc.vertes_at_ugrid.net>
 pkgname=mongodb
 pkgver=3.2.4
-pkgrel=1
+pkgrel=2
 pkgdesc='A high-performance, open source, schema-free document-oriented database'
 url='http://www.mongodb.org'
 arch='x86_64'
 license='AGPL3'
 pkgusers="mongodb"
 depends=
-depends_dev="scons openssl-dev pcre-dev snappy-dev boost-dev asio-dev libpcap-dev"
+depends_dev="scons openssl-dev pcre-dev snappy-dev boost-dev asio-dev libpcap-dev wiredtiger-dev"
 makedepends="$depends_dev"
 install="$pkgname.pre-install"
 source="http://downloads.mongodb.org/src/mongodb-src-r${pkgver}.tar.gz
_at_@ -48,6 +48,7 @@ _buildopts="
 		--disable-warnings-as-errors \
 		--use-system-boost \
 		--use-system-pcre \
+		--use-system-wiredtiger \
 		--use-system-snappy \
 		--use-system-zlib \
 	"
-- 
2.8.1
---
Unsubscribe:  alpine-aports+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-aports+help_at_lists.alpinelinux.org
---
Received on Thu Apr 14 2016 - 09:45:47 GMT