Mail archive
alpine-aports

[alpine-aports] [PATCH] testing/firetools: update to 0.9.40.1

From: Stuart Cardall <developer_at_it-offshore.co.uk>
Date: Sun, 24 Jul 2016 21:12:47 +0000

---
 testing/firetools/APKBUILD               | 22 ++++++---------
 testing/firetools/fix-qt-configure.patch | 46 --------------------------------
 2 files changed, 8 insertions(+), 60 deletions(-)
 delete mode 100644 testing/firetools/fix-qt-configure.patch
diff --git a/testing/firetools/APKBUILD b/testing/firetools/APKBUILD
index 670c137..e5f1988 100644
--- a/testing/firetools/APKBUILD
+++ b/testing/firetools/APKBUILD
_at_@ -1,22 +1,18 @@
 # Contributor: Stuart Cardall <developer_at_it-offshore.co.uk>
 # Maintainer: Stuart Cardall <developer_at_it-offshore.co.uk>
 pkgname=firetools
-pkgver=0.9.30
+pkgver=0.9.40.1
 pkgrel=0
 pkgdesc="Firejail sandbox launcher integrated with the system tray"
 url="https://l3net.wordpress.com/projects/firejail/#firetools"
 arch="all"
 license="GPL2"
-depends="firejail xterm icu-libs"
-#depends="firejail xterm" #building against qt5 requires v.5.60 which is currently in edge
+depends="firejail xterm qt5-qtsvg mesa-dri-swrast"
 depends_dev=""
-#makedepends="$depends_dev qt5-qtbase-dev qt5-qtsvg-dev"
-makedepends="$depends_dev qt-dev"
+makedepends="$depends_dev qt5-qtbase-dev qt5-qtsvg-dev"
 install=""
 subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/netblue30/firetools/archive/$pkgver.tar.gz
-	fix-qt-configure.patch
-	"
+source="$pkgname-$pkgver.tar.gz::https://github.com/netblue30/firetools/archive/$pkgver.tar.gz"
 
 builddir="$srcdir"/$pkgname-$pkgver
 build() {
_at_@ -27,6 +23,7 @@ build() {
 		--prefix=/usr \
 		--sysconfdir=/etc \
 		--mandir=/usr/share/man \
+		--with-qmake=/usr/lib/qt5/bin/qmake \
 		|| return 1
 	make || return 1
 }
_at_@ -36,9 +33,6 @@ package() {
 	make DESTDIR="$pkgdir" install || return 1
 }
 
-md5sums="11ddf9c6645f2d218e9cc5ad20070277  firetools-0.9.30.tar.gz
-2f8c60628d3155c30d988a8b5745916a  fix-qt-configure.patch"
-sha256sums="b54e3ae5f619a4e77f9a0044b791ea0cc86ccaf9ad07014898222bc8ae0bd56d  firetools-0.9.30.tar.gz
-9788d0b5c3738fe12b41cd9040f1c8b9a3718e57809d76c12b67ff79b818f4e7  fix-qt-configure.patch"
-sha512sums="237e1dc0b091874f34a326cca799a9b515861ff8966e319c6b79a6cd717f74d38d39fbd1cbbdaa85563cbfd3eddf61c204d1acf4caf9923c020638080225b199  firetools-0.9.30.tar.gz
-3a732d6fbd7e93b9bbd0cdf6484aff339069304333a319273e43d3147a32476d0812a7779187a5874a9d59f2f6bf5307fc2b93acf39f631e68f9d9eb8eddb5b5  fix-qt-configure.patch"
+md5sums="c127fb6433e1a74b2065c311bb2d3726  firetools-0.9.40.1.tar.gz"
+sha256sums="518d4af3a761dff417208e2fc4ce8ae2e897ef03db1096d636e22d606b21edf8  firetools-0.9.40.1.tar.gz"
+sha512sums="8a148ed9608d15074e9d8f4f947f1af6a75a5b03976835c40df7b9f1efb937914e0c08d44b5c71637fba17a189d61707ef613230a11ba29d71f305b8934dfb5b  firetools-0.9.40.1.tar.gz"
diff --git a/testing/firetools/fix-qt-configure.patch b/testing/firetools/fix-qt-configure.patch
deleted file mode 100644
index c0db8c9..0000000
--- a/testing/firetools/fix-qt-configure.patch
+++ /dev/null
_at_@ -1,46 +0,0 @@
---- firetools-0.9.30/configure
-+++ firetools-0.9.30/configure.new
-_at_@ -3811,18 +3811,24 @@
- 		as_fn_error $? "*** Please install Qt5 svg support - apt-get install libqt5svg5 ***" "$LINENO" 5
- 	fi
- 
--# Arch Linux 64bit
-+# Arch Linux 64bit & Alpine Linux
- elif test -f /usr/lib/libQt5Core.so
- then
-+	if test -d /usr/lib/qt5
-+	then
-+		qtdir='qt5'
-+	else
-+		qtdir='qt'
-+	fi
-         echo "Found qt5 library in /usr/lib directory"
-         # check libqt5svg5 library
--        if test -f /usr/lib/qt/plugins/imageformats/libqsvg.so
-+        if test -f /usr/lib/$qtdir/plugins/imageformats/libqsvg.so
-         then
-                 echo "Found qt5 svg library"
-         else
-                 as_fn_error $? "*** Please install Qt5 svg support - pacman -S qt5-svg ***" "$LINENO" 5
-         fi
--        if test -f /usr/lib/qt/plugins/iconengines/libqsvgicon.so
-+        if test -f /usr/lib/$qtdir/plugins/iconengines/libqsvgicon.so
-         then
-                 echo "Found qt5 svg icon library"
-         else
-
---- firetools-0.9.30/configure
-+++ firetools-0.9.30/configure.new
-_at_@ -3939,6 +3939,11 @@
- 		QMAKE=/usr/lib64/qt4/bin/qmake
- 	fi
- 
-+        # fix for Alpine Linux
-+        if test -f /usr/lib/qt5/bin/qmake; then
-+                QMAKE=/usr/lib/qt5/bin/qmake
-+        fi
-+
- 	if test -z "$QMAKE"
- 	then
- 		as_fn_error $? "qmake is missing, please install Qt4 or Qt5 development packages." "$LINENO" 5
-
-- 
2.9.1
---
Unsubscribe:  alpine-aports+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-aports+help_at_lists.alpinelinux.org
---
Received on Sun Jul 24 2016 - 21:12:47 GMT