Mail archive

Re: [alpine-aports] [PATCH] Add support for ppc64le

From: James Cloos <>
Date: Fri, 20 Jan 2017 14:35:16 -0500

Newer ppcle hardware supports ieee 128 bit float now. IBM decided to
switch from double-double to proper 128 bit some time ago.

(They only had double-double initially because it was easy; they wrote
microcode to support it using the then-current processors' 64bit float
hardware. Later processors added double-double hardware.)

Musl of course only supports ieee floats.

Alpine probably needs two ppcle versions; one for older double-double
hardware which sets long double to 64 bits, and another for newer
systems which sets long double to 128 bits.

I *think* all power8 systems support ieee 128.

James Cloos <>         OpenPGP: 0x997A9F17ED7DAEA6
Received on Fri Jan 20 2017 - 14:35:16 GMT