Mail archive
alpine-aports

Re: [alpine-aports] [PATCH] main/cairo: upgrade to 1.14.8

From: Valery Kartel <valery.kartel_at_gmail.com>
Date: Mon, 6 Feb 2017 12:31:52 +0200

oh, I remove it from depends_dev, but forgot to add to makedepends.

Just a sec. I'll make a v2 patch

2017-02-06 11:33 GMT+02:00 Timo Teras <timo.teras_at_iki.fi>:

> On Sun, 5 Feb 2017 00:24:26 +0200
> Valery Kartel <valery.kartel_at_gmail.com> wrote:
>
> > --
> > --- a/main/cairo/APKBUILD
> > +++ b/main/cairo/APKBUILD
> > -depends_dev="fontconfig-dev freetype-dev libpng-dev libxrender-dev
> > pixman-dev
> > - xcb-util-dev glib-dev libxext-dev"
> > +depends_dev="fontconfig-dev freetype-dev libxrender-dev pixman-dev
> > + xcb-util-dev libxext-dev $pkgname-tools"
>
> Why are you removing glib-dev and libpng-dev ?
>
> The build now failed with:
>
> checking for GOBJECT... no
> checking whether cairo's gobject functions feature could be enabled...
> no (requires gobject-2.0 glib-2.0 >= 2.14
> http://download.gnome.org/pub/GNOME/sources/glib/)
>
>



---
Unsubscribe:  alpine-aports+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-aports+help_at_lists.alpinelinux.org
---
Received on Mon Feb 06 2017 - 12:31:52 GMT