Mail archive
alpine-aports

[alpine-aports] [PATCH 10/13] main/rrdtool: dont install in /usr/local

From: Tuan M. Hoang <tmhoang_at_flatglobe.org>
Date: Fri, 17 Mar 2017 07:10:14 -0400

abuild/postcheck() complains about not putting files in /usr/local

---
 main/rrdtool/APKBUILD                        |  2 ++
 main/rrdtool/dont-install-in-usr-local.patch | 39 ++++++++++++++++++++++++++++
 2 files changed, 41 insertions(+)
 create mode 100644 main/rrdtool/dont-install-in-usr-local.patch
diff --git a/main/rrdtool/APKBUILD b/main/rrdtool/APKBUILD
index d0c43fbbc2..25bd2994e3 100644
--- a/main/rrdtool/APKBUILD
+++ b/main/rrdtool/APKBUILD
_at_@ -17,6 +17,7 @@ source="http://oss.oetiker.ch/$pkgname/pub/$pkgname-$pkgver.tar.gz
 	lua-install-cmod.patch
 	libm-underlinking.patch
 	no-posix-fallocate.patch
+	dont-install-in-usr-local.patch
 	rrdcached.initd
 	"
 
_at_@ -139,4 +140,5 @@ sha512sums="b980e36932683dbe2c2793c291c34e1c3a7fba208bda35b4b2d4fc994a9539c3c19f
 0be4ebb864233cf32fa70c872f5421b2da50ad39d6a265c2f5869337b40647c0b88011ccf41fe17a8d35de915ca1c38d04d67696118e1e32ff774221b1816ab6  lua-install-cmod.patch
 94449972ccc7d1a057c2b827c041a16de1667c280a47ef30c1323ec9168812a96374704cc42dd832a30b8cc08d7fad94da44ff3695c66f3a0d324a87158fc23c  libm-underlinking.patch
 00d079161551a75f8d4fe5085741d45d9c6b06be0a5163090143c6ab47710e29633414bee4dd68bbf950bf0ba1796bf4623b4f307477265a48f49514c8b790ab  no-posix-fallocate.patch
+839d9a2fbb74332cc9d0de18828f1496103b0cca6f05b3f88437dff6289954952f51350dcf01543d234ded19798115d400d9d61722e7193cd7f2bce47c14f6be  dont-install-in-usr-local.patch
 c0c27b2c2dfa8e7ec1cb1160d2bda8d7996bbea67f4ce7779da029f583c35e5e415cf46e2a1e5cb8ed2e63d2c58a68fd7471ee6bd820db4c0f4eeeb5c252f8a3  rrdcached.initd"
diff --git a/main/rrdtool/dont-install-in-usr-local.patch b/main/rrdtool/dont-install-in-usr-local.patch
new file mode 100644
index 0000000000..da63381386
--- /dev/null
+++ b/main/rrdtool/dont-install-in-usr-local.patch
_at_@ -0,0 +1,39 @@
+
+abuild/postcheck() complains about not putting files in /usr/local
+
+---
+ bindings/lua/compat-5.1r5/compat-5.1.lua | 4 ++--
+ configure.ac                             | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/bindings/lua/compat-5.1r5/compat-5.1.lua b/bindings/lua/compat-5.1r5/compat-5.1.lua
+index b662270..0179122 100644
+--- a/bindings/lua/compat-5.1r5/compat-5.1.lua
++++ b/bindings/lua/compat-5.1r5/compat-5.1.lua
+_at_@ -52,8 +52,8 @@ package.path = LUA_PATH or os.getenv("LUA_PATH") or
+ package.cpath = LUA_CPATH or os.getenv("LUA_CPATH") or
+              "./?.so;" ..
+              "./l?.so;" ..
+-             "/usr/local/lib/lua/5.0/?.so;" ..
+-             "/usr/local/lib/lua/5.0/l?.so"
++             "/usr/lib/lua/5.0/?.so;" ..
++             "/usr/lib/lua/5.0/l?.so"
+ 
+ --
+ -- make sure require works with standard libraries
+diff --git a/configure.ac b/configure.ac
+index 5270b22..8d87da9 100644
+--- a/configure.ac
++++ b/configure.ac
+_at_@ -864,7 +864,7 @@ LUA_EOF
+           AC_MSG_WARN(Setting Lua include and lib flags to defaults in compat-5.1 and lua 5.1 sources)
+           LUA_CFLAGS="-I/usr/local/include -I/usr/local/include/lua -I/usr/local/include/lua/$lua_vdot"
+           LUA_LFLAGS="-L/usr/local/lib -L/usr/local/lib/lua -L/usr/local/lib/lua/$lua_vdot $lua_libs"
+-          LUA_INSTALL_CMOD="/usr/local/lib/lua/$lua_vdot"
++          LUA_INSTALL_CMOD="/usr/lib/lua/$lua_vdot"
+         fi
+ 
+         dnl pass additional lua options
+-- 
+2.11.1
+
-- 
2.11.1
---
Unsubscribe:  alpine-aports+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-aports+help_at_lists.alpinelinux.org
---
Received on Fri Mar 17 2017 - 07:10:14 GMT