Mail archive
alpine-aports

Re: [alpine-aports] [PATCH v2] main/guile: upgrade to 2.2.0

From: Valery Kartel <valery.kartel_at_gmail.com>
Date: Thu, 6 Apr 2017 16:16:32 +0300

on my alpine lxc it builds well, but fails to build on travis-ci with
Segmentation fault ((

/bin/bash: line 5: 31384 Segmentation fault (core dumped)
GUILE_AUTO_COMPILE=0 ../meta/build-env guild compile
--target="x86_64-alpine-linux-musl" -Wunbound-variable
-Wmacro-use-before-definition -Warity-mismatch -Wformat -L
"/home/travis/build/alpinelinux/aports/main/guile/src/guile-2.2.0/module"
-L "/home/travis/build/alpinelinux/aports/main/guile/src/guile-2.2.0/module"
-L "/home/travis/build/alpinelinux/aports/main/guile/src/guile-2.2.0/guile-readline"
-o "language/cps/effects-analysis.go"
"language/cps/effects-analysis.scm"

make[2]: *** [Makefile:2255: language/cps/effects-analysis.go] Error 139



Don't have any idea why...

https://github.com/alpinelinux/aports/pull/1218



2017-04-06 15:11 GMT+03:00 Valery Kartel <valery.kartel_at_gmail.com>:

> Ok, I add bash to makedepends. But I can't reproduce errors you have.
>
> I'll made PR to github to see how travis-ci builds it.
>
> 2017-04-03 11:30 GMT+03:00 Leonardo Arena <rnalrd_at_gmail.com>:
>
>> Hi,
>>
>> On 20/03/2017 14:26, Valery Kartel wrote:
>> > switch to https:// source url
>> >
>> > ---
>> > v1 -> v2: force use /bin/bash for building
>> > ---
>> > main/guile/APKBUILD | 20 ++++++++------------
>> > 1 file changed, 8 insertions(+), 12 deletions(-)
>> >
>>
>> unfortunately it fails again with:
>>
>>
>> /bin/bash: line 6: 13838 Segmentation fault GUILE_AUTO_COMPILE=0
>> ../meta/build-env guild compile --target="x86_64-alpine-linux-musl" -O1
>> -L "/home/larena/aports/main/guile/src/guile-2.2.0/module" -L
>> "/home/larena/aports/main/guile/src/guile-2.2.0/guile-readline" -o
>> "system/vm/assembler.go" "../module/system/vm/assembler.scm"
>> make[2]: *** [Makefile:1928: system/vm/assembler.go] Error 139
>> make[2]: *** Waiting for unfinished jobs....
>> wrote `ice-9/pretty-print.go'
>> /bin/bash: line 6: 13905 Segmentation fault GUILE_AUTO_COMPILE=0
>> ../meta/build-env guild compile --target="x86_64-alpine-linux-musl" -O1
>> -L "/home/larena/aports/main/guile/src/guile-2.2.0/module" -L
>> "/home/larena/aports/main/guile/src/guile-2.2.0/guile-readline" -o
>> "system/vm/disassembler.go" "../module/system/vm/disassembler.scm"
>> make[2]: *** [Makefile:1928: system/vm/disassembler.go] Error 139
>> wrote `system/vm/debug.go'
>> make[2]: Leaving directory
>> '/home/larena/aports/main/guile/src/guile-2.2.0/bootstrap'
>> make[1]: *** [Makefile:1857: all-recursive] Error 1
>> make[1]: Leaving directory '/home/larena/aports/main/guil
>> e/src/guile-2.2.0'
>> make: *** [Makefile:1743: all] Error 2
>>
>> Also, although bash is pulled in by libtool, to be correct it should be
>> added to makedepends.
>>
>> Thanks
>>
>> |_eo
>>
>>
>



---
Unsubscribe:  alpine-aports+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-aports+help_at_lists.alpinelinux.org
---
Received on Thu Apr 06 2017 - 16:16:32 UTC