Mail archive
alpine-aports

[alpine-aports] [PATCH] testing/hplip: upgrade to 3.19.1

From: Paul Bredbury <brebs_at_sent.com>
Date: Sat, 2 Feb 2019 14:00:22 +0000

Removed lite build (and so now requires python-dev), which prevented
scanimage from noticing a Photosmart 5520 network printer/scanner.
---
 testing/hplip/APKBUILD | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/testing/hplip/APKBUILD b/testing/hplip/APKBUILD
index dc51efc791..899933ee28 100644
--- a/testing/hplip/APKBUILD
+++ b/testing/hplip/APKBUILD
_at_@ -3,14 +3,14 @@
 # Contributor: Timo Teräs <timo.teras_at_iki.fi>
 # Contributor: Valery Kartel <valery.kartel_at_gmail.com>
 pkgname=hplip
-pkgver=3.18.10
-pkgrel=2
+pkgver=3.19.1
+pkgrel=1
 pkgdesc="Drivers for HP printers and scanners"
 arch="x86 x86_64" # missing sane on several arches
 url="http://hplipopensource.com"
 license="GPL"
 depends=""
-makedepends="libjpeg-turbo-dev net-snmp-dev cups-dev libusb-dev sane-dev gawk"
+makedepends="libjpeg-turbo-dev net-snmp-dev cups-dev libusb-dev sane-dev gawk python-dev"
 subpackages="$pkgname-doc $pkgname-libs sane-backend-hpaio:sane"
 source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
 	fix-includes.patch
_at_@ -29,7 +29,6 @@ build() {
 	cd "$builddir"
 	./configure --prefix=/usr \
 		--with-docdir=/usr/share/doc/$pkgname \
-		--enable-lite-build \
 		--disable-doc-build \
 		--disable-gui-build \
 		--disable-fax-build \
_at_@ -66,7 +65,7 @@ sane() {
 	echo "hpaio" > "$subpkgdir"/etc/sane.d/dll.d/hpaio
 }
 
-sha512sums="8e744608f1da0e24afbeea814973363d95bbff15a7430c8471d5a53c4a9e772b141e5cd7e69ea03826d1b2e4544e9aabaedc148f2b6577339ef9b2a6d4431c96  hplip-3.18.10.tar.gz
+sha512sums="b1d663a3538a19ab2c195bc627c765b9dded047b0431f6fc2096a8a31b4efb5cf52c88ad9665a2d78893ba66c1c47ccf79c161965f308a27eeeb11b156b446c8  hplip-3.19.1.tar.gz
 173f0c2bbf0daefc717282bf125d3fd94b3914da0754078c45b58b09ab841672aae9238ca8fc0448486a871e40fc50f960da17c1e07ad3f04053d217ed634498  fix-includes.patch
 dbce7d859661b1a03847edf91db755c9b3d1ad7c2d3173741ecd89b954d1595d71f1adcbd481e81821ebd58cd9ae23adcef1cc026cfa09928fb0cba599781cd1  types-musl.patch
 ac436b54aecc0c2a7fc0eb5ae8e28d483c1efd5bd9385b0a1480fb78b8ccdd28ef85db86a980aec5ca093e9095d5714f93df095bf606e9a9c919f07c64e29697  disable_upgrade.patch
-- 
2.20.1
---
Unsubscribe:  alpine-aports+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-aports+help_at_lists.alpinelinux.org
---
Received on Sat Feb 02 2019 - 14:00:22 UTC