Mail archive
alpine-aports

[alpine-aports] [PATCH 1/x] community/ocaml: upgrade to 4.07.1

From: alpine-mips-patches <info_at_mobile-stream.com>
Date: Fri, 22 Feb 2019 12:53:47 +0000

- add binutils-dev to makedepends to improve support for native
  object files in ocamlobjinfo. This causes no changes in runtime
  dependencies because binutils is pulled via gcc already.

- tell ocaml we are building it with PIC enabled to reflect the
  fact in /usr/lib/ocaml/Makefile.config and similar places.

- remove CFLAGS joggling: ocaml build system ignores CFLAGS etc
  from the environment. And -fPIC is ensured by the above change.

- set the "preprocessed assembler" command explicitly. Same for
  "assembler" even if the latter is apparently unused in build on
  non-Windows systems.

- remove '--no-curses': it is a no-op.

- abuild detects no textrels on x86_64 at least so update options.
---
 community/ocaml/APKBUILD | 27 ++++++++++++---------------
 1 file changed, 12 insertions(+), 15 deletions(-)
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index ad254c7b6a..7a3d3dabef 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
_at_@ -2,15 +2,15 @@
 # Contributor: Jakub Jirutka <jakub_at_jirutka.cz>
 # Maintainer: Jakub Jirutka <jakub_at_jirutka.cz>
 pkgname=ocaml
-pkgver=4.06.1
-pkgrel=2
+pkgver=4.07.1
+pkgrel=0
 pkgdesc="Main implementation of the Caml programming language"
 url="http://ocaml.org/"
 arch="aarch64 ppc64le x86_64"
 license="LGPL-2.1-or-later-WITH-linking-exception"
 depends="$pkgname-runtime=$pkgver-r$pkgrel gcc"
-makedepends="gdbm-dev libc-dev ncurses-dev zlib-dev"
-options="textrels"
+makedepends="gdbm-dev libc-dev ncurses-dev zlib-dev binutils-dev"
+[ "$CARCH" = "x86_64" ] || options="textrels"
 subpackages="
 	$pkgname-doc
 	$pkgname-dev
_at_@ -28,16 +28,16 @@ builddir="$srcdir/$pkgname-$pkgver"
 build() {
 	cd "$builddir"
 
-	# Strip out -fomit-frame-pointer due to -pg.
-	export CFLAGS="${CFLAGS/-fomit-frame-pointer/} -fPIC"
-
 	./configure \
-		-cc "${CC:-gcc}" \
+		--prefix /usr \
 		--bindir /usr/bin \
 		--libdir /usr/lib/ocaml \
 		--mandir /usr/share/man \
-		--no-curses
-	make -j1 world.opt
+		-cc "${CC:-gcc}" \
+		-as "${CC:-gcc} -c" \
+		-aspp "${CC:-gcc} -c" \
+		-fPIC
+	make world.opt
 }
 
 check() {
_at_@ -50,10 +50,7 @@ check() {
 package() {
 	cd "$builddir"
 
-	make install \
-		BINDIR="$pkgdir"/usr/bin \
-		LIBDIR="$pkgdir"/usr/lib/ocaml \
-		MANDIR="$pkgdir"/usr/share/man
+	make DESTDIR="$pkgdir" install
 
 	install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
 	install -Dm644 Changes "$pkgdir"/usr/share/doc/$pkgname/Changes
_at_@ -122,7 +119,7 @@ _submv() {
 	rmdir -p "$pkgdir"/${path%/*} 2>/dev/null || true
 }
 
-sha512sums="42560874ce363212fa4e862138d7260113bc8dff8b39c040332bbd9b039ba938788344ba8ce63ffc0a251bf21a6e493f3c1e505b6f51db6fec4d21578921060e  ocaml-4.06.1.tar.gz
+sha512sums="a7faed1759f76b91afb0922de159240cc11d68f89e2136d2f3add4d3e66fe923f27a094a937a7d7e73727a1675864e8ff41882eeaa4212d8c4dfeb2811e1707a  ocaml-4.07.1.tar.gz
 b42af74ae80428a0488bbb182ca5f48d35ce34d6ba336aa10904a78863e7e1e6b61303d5cd3ad89cba5329cb0983692ba92341e2058ea3e31bb22aa4f7b46dd8  compile-without-debug-info.patch
 75c67e143a4a05b334bdebbad48ded1e04d383d8ea9b747df2633a5af96b1115b502510faf57753c71bbac38fbc9d9746b167861a63b2fd295901db0d22ea317  fix-mcontext-fields.patch
 b2cef41400b31c1dcfd206c1534827f7b33b0afd6234b26fb95cf15c092affa85c27a615c14ece254ec326430f31b58ca70b9cc23a84ebf8baac2624bd5b0a71  fix-segfault-in-ppc64le.patch"
-- 
2.20.1
---
Unsubscribe:  alpine-aports+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-aports+help_at_lists.alpinelinux.org
---
Received on Fri Feb 22 2019 - 12:53:47 UTC