Mail archive
alpine-devel

Re: [alpine-devel] First abuild attempt

From: Timo Teräs <timo.teras_at_iki.fi>
Date: Thu, 30 Jul 2009 08:23:29 +0300

Mark Constable wrote:
> For a first attempt at building I package I copied main/nano to
> a parallel build tree and modified the configure line to include
> --enable-color and --enable-nanorc, then abuild -i.
>
> My newer package compiled okay and went to $REPODEST (being
> /home/packages/alpine/nano*) but did not install.
>
> How do I install a package directly as per pacman -U /path/to/package?
>
> How do I create the custom local package database, again, like
> the Arch repo-add command?
>
> (I couldn't find any info about the package db on the trac wiki)

In alpine 1.8 or 1.9 series?

"apk add /path/to/package" should work in 1.9. If the version number
is the same as existing it might or might not work (I'm not sure if
I fixed that to work properly).

Local repository is created with "apk index *.apk | gzip -9 > APK_INDEX.gz".
And you add the path to direcotry containing the apks and index to
/etc/apk/repositories.

Though this will change in next 1.9 release, as we've implemented
package signatures. That's one of the reasons it has not been
documented yet.

There's also a bunch of new options and features in apk that we
will document after the next 1.9 release. I hope release happens
this week or early next week.

- Timo




---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Thu Jul 30 2009 - 08:23:29 UTC