Mail archive
alpine-devel

Re: [alpine-devel] Where would x11/APKINDEX.tar.gz go?

From: Mark Constable <markc_at_renta.net>
Date: Thu, 30 Jul 2009 22:52:13 +1000

Natanael Copa wrote:
> So, yes repo have been unstable latest week due to the index format
> change. It should be working now. Sorry for the mess.

Not at all. I understand you are in the middle of significant changes.
I just hope you guys don't mind me making a lot of noise about things
I probably should not be messing around with.

 apk --allow-untrusted update
 apk --allow-untrusted add xorg-server-dev

Both worked smoothly so now I can proceed with building mrxvt :)

***

FWIW, regarding x86_64, I just tried a test of chrooting into the
alpine devel partition I have here from a x86_64 Archlinux kernel
without using "linux32 chroot" (so uname -m == x86_64) and changed
CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe" in /etc/abuild.conf
and tried building uclibc and ncurses... uclibc compiled but it was
still a 32bit lib I think with a little (hopefully) tweaking to use
libc/sysdeps/linux/x86_64/ and remove an obvious 32bit patch then
I might be able to get a 64bit uclibc compiled.

Maybe there is more involved but I do have the motivation to try.

--markc


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Thu Jul 30 2009 - 22:52:13 UTC