Mail archive
alpine-devel

[alpine-devel] postgresql upgrade to 8.4

From: Natanael Copa <natanael.copa_at_gmail.com>
Date: Wed, 12 Aug 2009 18:04:53 +0200

Hi,

This is just a heads up for you who uses postgresql.

I am upgrading postgres to 8.4. This will require that you manually
pg_dumpall *before* the upgrade. The .pre-upgrade script will abort the
upgrade if it detects older than 8.4 running, displaying the following
information:

* You are upgrading to postgres 8.4 wich is not compatible with the running
* See: http://www.postgresql.org/docs/8.4/interactive/install-upgrading.html
*
* The corresponding steps for Alpine Linux is:
*
* pg_dumpall -U postgres > dumpfile
* /etc/init.d/postgresql stop
* apk add -u postgresql
* /etc/init.d/postgresql setup
* /etc/init.d/postgresl start
* psql -U postgres -f dumpfile
*


-nc




---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Wed Aug 12 2009 - 18:04:53 UTC