Mail archive
alpine-devel

Re: [alpine-devel] MediaProxy package

From: Natanael Copa <natanael.copa_at_gmail.com>
Date: Mon, 16 Nov 2009 11:51:00 +0100

On Fri, 2009-11-13 at 21:03 -0500, Andrew Manison wrote:
> Hi,
>
> Here is the patch for MediaProxy. It required creating packages for a
> couple of Python installation packages as well. Hopefully this will all
> work.

Looks great! I committed and did some minor fixes, like adding
python-dev to makedepends and quoting "$srcdir" and "$pkgdir" incase
someone should have their aports tree in ~/"My Alpine Projects/aports"
or similar.

...
> +pkgname=python26-buildutils
> +_pkgname=`echo $pkgname |sed -e 's,^python26-,,'`
...

I'll change that to:

_pkgname=${pkgname#python26-}

We parse all APKBUILDS to trace dependencies. If every APKBUILD does a
fork or two that process would be slow at some point so we try to avoid
forks in global scope.

> +pkgver=0.6c11

Just so you know, apk-tools consider 0.6c9 > 0.6c11. When letter after
digit is found it does string sort. (for things like lha-1.14i)

not sure what the c in there means, but if its patch-level then suffix
_p11 would be the right thing.

oh.. I needed to add python-dev to makedepends.

Thanks alot!

-nc



---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Mon Nov 16 2009 - 11:51:00 UTC