Mail archive
alpine-devel

Re: [alpine-devel] Re: help: freepbx install on alpine linux

From: Kenny Aral <oggyk22_at_ufl.edu>
Date: Fri, 23 Apr 2010 18:18:53 -0400 (EDT)

Thanks for the suggestion, Harry. That corrected the error I was
getting. However, now I am getting a new error that I've spent the
whole day trying to fix. I have created the MySQL databases called
asterisk and asteriskcdrdb. I granted all privileges using:

mysql> grant all privileges on asterisk.* to
asteriskuser_at_localhost identified by 'amp109';
mysql> grant all privileges on asteriskcdrdb.* to
asteriskuser_at_localhost identified by 'amp109';
mysql> flush privileges;

When I run the script the output is:

# ./install_amp
...
...
Connecting to database..FAILED
DB Error: connect failed, [nativecode=No such file or directory]
** mysql://asteriskuser:amp109_at_localhost/asterisk
Try running ./install_amp --username=user -password=pass
[FATAL] Cannot connect to database

I don't understand why its giving me a "no such file" error when
the database definitely exists. If I change the IP address from
'localhost' to the actually IP address of the server I am running
'192.168.1.114' the output is:

# ./install_amp
...
...
Connecting to database..FAILED
DB Error: connect failed, [nativecode=Connection refused] **
mysql://asteriskuser:amp109_at_192.168.1.114/asterisk
Try running ./install_amp --username=user -password=pass
[FATAL] Cannot connect to database

This time I get "Connection refused." I have tried running the
script with --skip networking uncommented/commented in
/etc/mysql/my.cnf with no success. At this point I'm stumped as to
why its not working. This is the very last part of the
installation too.

On Fri Apr 23 02:27:55 EDT 2010, Harry Lachanas
<grharry_at_freemail.gr> wrote:

>
>>
>> Using asterisk as PBX Engine
>> Checking for Asterisk version..1.6.3.0
>> Checking for selinux..sh: getenforce: not found
>> OK
>> Connecting to database..PHP Fatal error: Class 'DB' not found in
>> /etc/freepbx-2.7.0/install_amp on line 974
>>
>> I am not sure if this is caused because getenforce is missing,
>> or if its for some other reason. Any ideas?
> Hi,
> I am very much interested in your efforts ...
>
> did you try this ???
>
> # install pear DB module
> pear channel-update pear.php.net
> pear install db
>
> Regards
> Harry.
>
>
>
>
>



--
ARAL,KENNY A
---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Fri Apr 23 2010 - 18:18:53 GMT