Mail archive
alpine-devel

Re: [alpine-devel] new aport utility: ap

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Tue, 14 Dec 2010 08:37:06 +0100

On Mon, 13 Dec 2010 13:26:54 -0600 (CST)
"Matt Smith" <mcs_at_darkregion.net> wrote:

> I'm wondering if we should have an extra sub-command that would allow
> one to search all APKBUILDs in their aports for their name or another
> contributor/maintainer's name.  This would allow contributors to keep
> track of which package(s) they're involved in.
>
> I'd actually just made a one-liner shell command for this prior to
> checking my e-mail: grep -rHi "Matt Smith" ~/aports/ | grep -E
> 'aports/(testing|main)/[^/]+/APKBUILD' | awk -F '/' '{print $5 "/"
> $6}' | sort -u

Right. The current lua script implementation is not really good for
this but could be done ofcourse. Currently the script will source each
APKBUILD and echo $pkgname $pkgver $source etc so variable expansion
works properly. In other words, the comments are currently ignored.

But yes. We need a tool for this.

> On Monday, December 13, 2010 9:22am, "Natanael Copa"
> <ncopa_at_alpinelinux.org> said: ...
> > We need a config file (/etc/ap.conf?) where you can list your aports
> > dirs.
> >
> > I am interested in feedback:
> >
> > Is 'ap' a good name for this command?
> >
> > Do we want 'ap <subcommand>' or ap-subcommand as a symlink? or
> > separate file?
> ...
>
> I think having a config file is a great idea.

Maybe /etc/aports/aports.conf

and move /etc/abuild.conf to /etc/aports/abuild.conf ?

> I also have a few ideas that I'd like to see what you think about:
> - Rename 'ap' to 'aports'

Will that not cause confusion? When you talk about aports, do you talk
about the aports tool or the ported applications, buildscripts?

> - Make 'ap' / 'aports' similar to 'apk' in regards to sub-commands;
> include abuild, abump, newapkbuild, etc. as sub-commands to 'ap' /
> 'aports' (e.g.: aports build -r, aports newapkabuild newpackage)

I was thinking of simplifying the abuild script, remove all the code
doing dependencies, recursive building etc, and let 'aports' utility do
that, but keep the shell script to do simple building. Like gentoo has
'emerge' and 'ebuild'

> - Rename /etc/abuild.conf to /etc/aports.conf and add variable(s) for
> 'ap' / 'aports' pointing to the local aports directory(s)

Hmm... We dont want 2 different tools? One that does the actuall
building and one that searches/analyzes the aports tree.

In any case i think we might want the aports.conf be
readable from shell scripts.

> - Matt
>

Thanks for the feedback!

-nc


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Tue Dec 14 2010 - 08:37:06 UTC