Mail archive
alpine-devel

Re: [alpine-devel] Alpine 2.2 Release Candidate 2

From: Jeremy Thomerson <jeremy_at_thomersonfamily.com>
Date: Fri, 29 Apr 2011 11:18:26 -0400

ncopa and list,

I installed RC1 last night on a newly-built home file server. Here are some
things I noticed or had questions about:

First, a little general info. I was building on a mini-itx Intel
motherboard / CPU combo, with a single 2TB drive that I wanted to be
data-only. I couldn't get it to boot from a card reader / SD card combo,
but I think that's probably a bios thing. I booted from a USB thumb drive.
I ran setup-alpine immediately after booting the first time. I tried using
the setup-disk that runs at the end of setup-alpine to configure my disk. I
wanted to run from ram, from the USB thumbdrive, and use the HD for
data-only, mostly just file storage.

   1. I was surprised that when setup-disk ran, it didn't show me any
   attributes of the disk to help me pick the right one. It just asks you to
   pick a disk (in my case sda or sdf) and you will erase everything. Showing
   me the disk size or name would have helped tremendously to make sure that I
   picked the HD and not the USB drive.
   2. There's a minor typo in setup-disk. It said "used for either
   traditional disk install data-only". It appears to be missing the word "or"
   3. When running setup-disk, got the following error: "Can't open
   /usr/share/syslinux/mbr.bin" Perhaps syslinux isn't installed by default?
   4. setup-disk failed altogether for me. mkfs dumped it's usage screen as
   if it had bad parameters sent to it.
   5. Setting up the repos was really slick! But, (extremely minor), it
   ended up with a double forward slash. This doesn't seem to affect anything,
   and I just manually removed it.
   6. lbu commit gives you the option of usb or sda. But on mine, I have to
   use "usbdisk", even though /etc/fstab says that the mount is "usb" (for some
   reason, despite /etc/fstab saying /dev/usb and /media/usb, my usb thumb
   drive shows up in /media/usbdisk)

That's what I noticed. Most are extremely minor. My box will not reboot at
all. If I issue "reboot", it will halt, but not power cycle. I'm going to
try to investigate that more this weekend.

Can I just do "apk update; apk upgrade" to get to RC2?

Thanks!

Jeremy Thomerson


On Fri, Apr 29, 2011 at 11:02 AM, Natanael Copa <ncopa_at_alpinelinux.org>wrote:

> Hi,
>
> I have uploaded Alpine 2.2 Release Candidate 2. It can be found in
> http://www.alpinelinux.org/cgi-bin/dl.cgi/v2.2/releases/x86
> http://www.alpinelinux.org/cgi-bin/dl.cgi/v2.2/releases/x86_64
>
> The 2.2.0 sharp release will be Tuesday next week. Please help
> testing ;)
>
> Have a nice weekend everyone.
>
> -nc
>
>
> ---
> Unsubscribe: alpine-devel+unsubscribe_at_lists.alpinelinux.org
> Help: alpine-devel+help_at_lists.alpinelinux.org
> ---
>
>



---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Fri Apr 29 2011 - 11:18:26 UTC