Mail archive
alpine-devel

Re: [alpine-devel] Alpine on Alix (was: Minimal ram requirements?)

From: Jeremy Thomerson <jeremy_at_thomersonfamily.com>
Date: Tue, 13 Nov 2012 08:27:41 -0600

Der,

  I had to have help getting my Alix going, too. nangel gave me a
syslinux.cfg file that made mine work. After making my bootable CF card, I
edited the file and then installed the CF card in the Alix and it worked.
Here's the file:

rt01 [/media/sda1]# cat syslinux.cfg
serial 0 38400
timeout 20
prompt 1
default grsec
label grsec
   kernel /boot/grsec
   append initrd=/boot/grsec.gz alpine_dev=sda1:vfat
modules=loop,squashfs,cramfs,sd-mod,usb-storage console=ttyS0,38400



On Fri, Nov 9, 2012 at 3:30 PM, Timo Teras <timo.teras_at_iki.fi> wrote:

> On Fri, 09 Nov 2012 21:51:21 +0100 Der Tiger
> <der.tiger.alpine_at_arcor.de> wrote:
>
> > Some time ago, I tried to get Alpine running on an Alix 2C3 system,
> > which is nearly identical to the 2D3, but the kernel (I suppose 2.6)
> > was crashing constantly. Most crashes occurred when I started larger
> > applications like Asterisk. BIOS version was 0.99h, the latest version
> > available, and I tested with MFGPT workaround enabled and disabled.
>
> I have multiple ALIX 2d3 boxes here, and most of them run Alpine 2.4.x
> and Asterisk 10. No problems.
>
> > May I ask which kernel you are using? Does Alpine require certain
> > kernel configuration parameters to run stable on Alix boards?
>
> I'm on kernel 3.3.x. and 3.4.x mostly.
>
> No special configuration needed. Except for the one box where I use the
> speaker output as GPIO. But even on that box it's done with sysfs
> calls instead of boot params.
>
> > I am quite sure my Alix board is _not_ defective, because there have
> > bin no issues running Voyage Linux and fli4l. Due to the problems
> > mentioned, the Alix was replaced by a considerably more powerful
> > Intel DN2800MT, but I would like to reactivate the Alix board for
> > supplementary purposes.
>
> - Timo
>



---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Tue Nov 13 2012 - 08:27:41 UTC