Mail archive
alpine-devel

Re: [alpine-devel] [2.6rc2] USB 3G Modems Not Working, Anymore

From: Der Tiger <der.tiger.alpine_at_arcor.de>
Date: Sat, 04 May 2013 15:08:12 +0200

ReHi,

Thanks for your help!

> When I had similar hw issues with network card drivers, I downgraded my
> server to the prev release.
Well, I tried to avoid the downgrade option, because this can cause
irreparable damage to the configuration ('backup' is your friend), but
since there seems to be no other solution available, I had no choice.

Anyway, there is poor to no documentation regarding the version
downgrade of Alpine systems using 'apk' available on the WWW. Therefore,
here a short how-to for documentation purposes I extracted form apk's
sources:

1) Backup your system
2) 'sudo nano /etc/apk/repositories' and change URL to whatever version
you need
3) 'sudo apk -Ufa upgrade', where 'U' updates the local repository
cache, 'f' forces some actions and 'a' tells apk to use the latest
version _a_vailable from the given repository, regardless of the (newer)
version currently installed.
4) 'sudo apk -r fix linux-grsec' to trigger syslinux installation

Being back to 2.5 the USB modem is working, again. Thanks to all for
your support!

Regards, Tiger


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Sat May 04 2013 - 15:08:12 UTC