Mail archive
alpine-devel

Re: [alpine-devel] Updated lua-sql-odbc Package

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Wed, 15 Jan 2014 11:16:10 +0100

On Tue, 14 Jan 2014 13:00:10 -0500
Robert Boisvert <rdboisvert_at_gmail.com> wrote:

> Please apply this patch for the lua-sql-odbc package.
>
> Thanks,
> Bob

It failed to apply with:
error: main/lua-sql-odbc/APKBUILD: does not exist in index

>Subject: [PATCH] Added support for SQL wide characters (original commit from
> ignacio 28004783c0fd57b0f77f2b768c4cad56555f5351)

I could not find any 28004783c0fd57b0f77f2b768c4cad56555f5351 in aports
tree or with google, so that commit id is not very informative.

I manually edited the patch to modify testing/lua-sql-odbc/APKBUILD.

I bumped pkgrel (so the builders actually build a new package)

I removed the lua dependency as you can build a C application and embed
lua in there (like haserl does). You dont need /usr/bin/lua from there.

I updated the commit message and pushed.

Thanks!

-nc


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Wed Jan 15 2014 - 11:16:10 GMT