Mail archive
alpine-devel

Re: [alpine-devel] Extreme latency on rt2x00 + hostapd + multi-BSS

From: Isan/Matt/Koryn <isangaft220_at_gmail.com>
Date: Mon, 27 Jan 2014 00:55:51 -0600

On Fri, Jan 24, 2014 at 8:03 AM, Natanael Copa <ncopa_at_alpinelinux.org> wrote:
> On Thu, 23 Jan 2014 19:48:41 -0600
> "Isan/Matt/Koryn" <isangaft220_at_gmail.com> wrote:
>
>> Hello all,
>> Recently I noticed that I was unable to view videos without constant
>> buffering on my wireless connection. I seem to have been having this
>> problem off and on for a while, however it became much worse recently,
>> with my ping exceeding 1000ms, right now it's averaging about 500ms,
>> which is much better than it was, although that's when pinging my
>> alpine box (which acts as the gateway/router/firewall for my network)
>> which should be much lower (~1ms). Checking the logs, I realized the
>> kernel is throwing the same error related to the
>> rt2x00queue_write_tx_frame symbol, as follows:
>>
>> Jan 23 18:40:59 security kern.err kernel: [16896.045803] ieee80211
>> phy0: rt2x00queue_write_tx_frame: Error - Dropping frame due to full
>> tx queue 2
> ...
>
>> I am using the linux-grsec kernel, and this occurs whether I'm using
>> the kernel from stable or edge.
>
> Can you test linux-vanilla too? If it happens with vanilla kernel then
> its an upstream issue otherwise it is likely introduced with grsecurity
> patch.
>
> -nc

The problem does occur in vanilla, so it is an upstream issue. Perhaps
this is fixed in 3.13? Otherwise I'll have to message the rt2x00 list
unless it's already been reported to them. Thanks.


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Mon Jan 27 2014 - 00:55:51 UTC