Mail archive
alpine-devel

Re: [alpine-devel] apk upgrade failure

From: Timo Teras <timo.teras_at_iki.fi>
Date: Mon, 3 Feb 2014 13:06:42 +0200

Hi,

On Wed, 29 Jan 2014 21:07:50 -0500
Sam Dodrill <shadow.h511_at_gmail.com> wrote:

> Running edge on a server of mine. Trying to upgrade it and I get this
> error message.
>
> genesect ~ > sudo apk upgrade
> ERROR: unsatisfiable constraints:
> Huh? Error reporter did not find the broken constraints.
>
> apk upgrade -f hangs and I can't seem to find another combination of
> flags that works. Any ideas?
>
> genesect ~ > apk --version
> apk-tools 2.4.0, compiled for x86_64.

We are experiencing something similar on the build servers and are
looking into it. Our issue seems to be related to audacity having
install_if audacity-plugins, and audacity-plugins makedepending on
audacity (via audacity-dev).

In all cases, sounds like issue in install_if handling. If you can post
the list of packages installed, and the packages in 'world' that would
be helpful. Thanks.

- Timo


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Mon Feb 03 2014 - 13:06:42 UTC