Mail archive
alpine-devel

Re: [alpine-devel] switching to musl

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Thu, 3 Apr 2014 22:25:46 +0200

On Thu, 3 Apr 2014 08:23:30 -0500
Jeff Pohlmeyer <yetanothergeek_at_gmail.com> wrote:

> On Wed, Apr 2, 2014 at 8:29 AM, Natanael Copa wrote:
> > On Wed, 2 Apr 2014 Jeff Pohlmeyer wrote:
>
> >> I had problems with the xf86-video drivers (vesa, nouveau, fbdev) not
> >> finding symbols in the Xorg executable.
> >> Tried to work around this by LD_PRELOAD'ing the binary, but that led
> >> to more missing symbols.
>
> > This should fix it:
> > http://git.alpinelinux.org/cgit/aports/commit/main/xorg-server?id=2d5f088aeb37d13fb9893ec5da4bd683f5b4e0f0
>
> Excellent!
>
> Actually I already had that update, but I am using an old-fashioned single
> xorg.conf file, so I had to copy/paste the new "Module" section into my
> xorg.conf to get it working.
>
> As an added bonus, the "column" command from util-linux has always been
> horribly broken with uclibc, but it's working great with musl!

Someone mentioned something about a bug with python3 on IRC. But when
testing with musl, bug was gone.


> This might not be the right place to bring it up, but I ran into a couple
> of issues with the "definitive guide" page at kaniini.dereferenced.org ...
>
> The page says to run:
> $ apk.static update
> $ apk.static upgrade --available --no-self-upgrade
>
> But this doesn't seem to have any effect if package caching is enabled,
> it just pulls the same old uclibc packages from the cache, so I guess
> the cache needs to be purged first?

This is unexpected. Might be a bug?

>
> It also says to modify /etc/mkinitfs/files.d/base, but that file
> no longer exists, it is now /etc/mkinitfs/features.d/base.files.

Yes, that change happened after kaniini's article. You should not need
edit anything that is related mkinitfs. (but i think there is a bug in
the post-upgrade script though, that copies .apk-new files)

> To be honest, I was afraid the musl switch might be a disaster, but I'm
> now becoming cautiously optimistic!

Yes, its scary! But the tests so far have been much better than
expected.

>
>
> - Jeff



---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Thu Apr 03 2014 - 22:25:46 UTC