Mail archive
alpine-devel

Re: [alpine-devel] libc-dev / Forcible removal of package

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Thu, 26 Jun 2014 11:37:11 +0200

On Thu, 26 Jun 2014 09:50:25 +0200
"Leslie P. Polzer | PORT ZERO" <polzer_at_port-zero.com> wrote:

> Hi folks,
>
> excellent work with the musl port!
>
> After upgrading to latest edge I have the following issue:
>
> % sudo /sbin/apk fix
> (1/1) [APK unavailable, skipped] Reinstalling libc-dev (0.5-r0)
> 1 errors; 1871 MiB in 370 packages
>
> I'm not sure whether libc-dev is still meant to be in world.
> apk also shows that it is an empty package.
>
> In an attempt to get rid of this empty package I tried to forcibly
> remove it, but there doesn't seem to be an option to do that.
> I guess this is by design?
>
> Thanks,
>
> Leslie
>

What happens when you do apk del libc-dev?

iirc the libc-dev is a meta package that is uspposed to pull in the correct libc headers so we don't need do:

if [ "$CLIBC" = musl ]; then depends="$depends musl-dev" ...


-nc


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Thu Jun 26 2014 - 11:37:11 UTC