Mail archive
alpine-devel

Re: [alpine-devel] [PATCH] Add "-s" short option for "--simulate"

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Wed, 2 Jul 2014 02:10:30 +0200

On Wed, 2 Jul 2014 11:52:12 +0300
Timo Teras <timo.teras_at_iki.fi> wrote:

> On Wed, 2 Jul 2014 09:26:03 +0200
> Natanael Copa <ncopa_at_alpinelinux.org> wrote:
>
> > On Mon, 30 Jun 2014 00:13:24 -0700
> > Isaac Dunham <ibid.ag_at_gmail.com> wrote:
> >
> > > On Mon, Jun 30, 2014 at 08:55:56AM +0200, Natanael Copa wrote:
> > > > On Sat, 28 Jun 2014 19:39:51 -0700
> > > > Isaac Dunham <ibid.ag_at_gmail.com> wrote:
> > > >
> > > > > Typing the long option gets old.
> > > > > ---
> > > > > src/apk.c | 10 +++++-----
> > > > > 1 file changed, 5 insertions(+), 5 deletions(-)
> > > >
> > > > Have you checked that it does not break apk info -s <package>?
> > > > (for displaying size usage)
> > >
> > > I had not.
> > > And it does break it.
> > >
> > > My apologies.
> >
> > I must admit that I like the idea though.
> >
> > I dont think 'apk info -s --simulate' makes much sense.
> >
> > Timo, are there some way to fix this, that is, disable or override
> > global options for some applets.
> >
> > I am not sure we want do that though...
>
> Currently no, could probably be done with little changes. Though, I'd
> prefer not to do it.

Ok. Lets leave it.

> Though having '-s' short for --simulate sounds like a good idea. I have
> missed that, and I believe apt-get does that too.
>
> Perhaps we should rename info -s to something else?

info -S?

But I don't like breaking compatibility. It always causes unexpected
breakages which requires nasty fixes.

-nc

> /Timo



---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Wed Jul 02 2014 - 02:10:30 UTC