Mail archive
alpine-devel

Re: [alpine-devel] [PATCH] testing/syslog-ng: update to 3.6.1

From: V.Krishn <vkrishn4_at_gmail.com>
Date: Fri, 28 Nov 2014 01:46:28 +0530

Thanks,
Seems ok, only getting now errors relating to starting 3.6.1
I think some of the files i.e have to modified too
syslog-ng-destination.std
syslog-ng-filter.std
syslog-ng.initd
syslog-ng.logrotate
syslog-ng-log.std
syslog-ng-options.std
syslog-ng.post-install
syslog-ng-source.std

Some msg while starting syslog-ng v3.6.1
------------------------------
[2014-11-27T20:09:59.753453] WARNING: Configuration file has no version
number, assuming syslog-ng 2.1 format. Please add _at_version: maj.min to the
beginning of the file to indicate this explicitly;
[2014-11-27T20:09:59.753481] WARNING: Configuration file format is too old,
syslog-ng is running in compatibility mode Please update it to use the syslog-
ng 3.6 format at your time of convinience, compatibility mode can operate less
efficiently in some cases. To upgrade the configuration, please review the
warnings about incompatible changes printed by syslog-ng, and once completed
change the _at_version header at the top of the configuration file.;
[2014-11-27T20:09:59.753500] WARNING: global: the default value of
chain_hostnames is changing to 'no' in syslog-ng 3.0, please update your
configuration accordingly;
[2014-11-27T20:09:59.753516] WARNING: global: the default value of
log_fifo_size() has changed to 10000 in syslog-ng 3.3 to reflect log_iw_size()
changes for tcp()/udp() window size changes;
[2014-11-27T20:09:59.755516] WARNING: input: sources do not remove new-line
characters from messages by default from syslog-ng 3.0, please add 'no-multi-
line' flag to your configuration if you want to retain this functionality;
[2014-11-27T20:09:59.755544] WARNING: the expected message format is being
changed for unix-domain transports to improve syslogd compatibity with syslog-
ng 3.2. If you are using custom applications which bypass the syslog() API,
you might need the 'expect-hostname' flag to get the old behaviour back;
[2014-11-27T20:09:59.755593] WARNING: file source: default value of
follow_freq in file sources has changed in syslog-ng 3.0 to '1' for all files
except /proc/kmsg;
[2014-11-27T20:09:59.755616] WARNING: Your configuration file uses an
obsoleted keyword, please update your configuration; keyword='log_prefix',
change='program_override'
[2014-11-27T20:09:59.755686] WARNING: template: the default value for
template-escape has changed to 'no' from syslog-ng 3.0, please update your
configuration file accordingly;
[2014-11-27T20:09:59.756444] WARNING: syslog-ng changed the default regexp
implementation to PCRE starting from syslog-ng 3.6, please ensure your regexp
works with PCRE or please specify type("posix") in filters explicitly;
[2014-11-27T20:09:59.756471] WARNING: filters do not store matches in macros
by default from syslog-ng 3.0, please update your configuration by using an
explicit 'store-matches' flag to achieve that;


-- 
Regards.
V.Krishn
> On Thu, Nov 27, 2014 at 04:36:09PM +0000, Stuart Cardall wrote:
> > update to 3.6.1 + docs subpkg
> 
> I know you've gotten it to build. But have you also verified that it
> works properly when installed (including dragging in the right runtime
> dependencies when they aren't installed already?)
> 
> Thanks,
> Isaac Dunham
> 
> 
> ---
> Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
> Help:         alpine-devel+help_at_lists.alpinelinux.org
> ---
---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Fri Nov 28 2014 - 01:46:28 GMT