Mail archive
alpine-devel

Re: [alpine-devel] alpine 3.1.0 RC3 released

From: IT Developer <developer_at_it-offshore.co.uk>
Date: Sat, 29 Nov 2014 03:03:53 +0000

I've been testing the 3.1 disk installs in Virtualbox. There seems to be
a problem with Xorg in 3.1 / possibly GTK (which affects the display
managers & desktops).

In 3.0 I have xfce / fluxbox running without any problems without a
Display Manager / with LXDM & with SLIM.

I've tried upgrading 3.0 to 3.1 & a clean install of 3.1 & with both I'm
unable to start a desktop with or without a Display Manager.

I noticed removing LXDM from 3.1 caused gtk2-xfce-engine to be upgraded.

Xorg logs showed:

Assertion failed: key-> initialized
(../include/privates.h:dixGetPrivateAddr: 1ddr: 122
lxdm-greeter-gtk Fatal IO error 0 (No error information) on X server :0.
** Message: xserver stop, restart. return status 6

SLIM just flashes when trying to login - it's logs show "slim: waiting
for X server to begin accepting connections"
------------------------------------------------------------------------

I also tested installing onto encrypted LVM:

3.0.6 - can open LUKS partitions but segfaults using luksFormat in
cryptsetup.
3.1 - can open & format LUKS partitions with cryptsetup.

*mkinitfs -c $MNT/etc/mkinitfs/mkinitfs.conf -b $MNT*

3.0.6 - mkinitfs creates $MNT/boot/grsec.gz (& not initramfs-grsec) -
renaming it manually works
3.1 - mkinitfs creates $MNT/boot/initramfs-grsec

Extlinux - on both 3.0.6 & 3.1:

*extlinux --install $MNT/boot --update*

It correctly identifies the boot partition but does not update
$MNT/boot/extlinux.conf

modifying APPEND in extlinux.conf to

*APPEND root=/dev/mapper/vg0-root modules=sd-mod,usb-storage,,ext4 quiet
cryptroot=/dev/sda2 cryptdm=lvmcrypt*

Gave me a bootable encrypted system.

I also noticed running 3.0.6 & 3.1 with more than 1 CPU sometimes gave
"kernel panic - not syncing: Fatal exception in interrupt" (with it
seeming to happen more often in 3.1 compared to 3.0.6) - resetting the
VM a few times eventually gives a usable system.

2.7 did not seem to be affected by this. 3.0.6 / 3.1 with one CPU ran
without any panics.

I now have 2 VM's with an Alpine 3.0 xfce / fluxbox desktop on encrypted
LVM & an Alpine 3.1 on encrypted LVM without a working desktop.

Stuart.



---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Sat Nov 29 2014 - 03:03:53 UTC