Mail archive
alpine-devel

Re: [alpine-devel] [PATCH] testing/mate-common: new aport

From: Natanael Copa <n_at_tanael.org>
Date: Tue, 16 Dec 2014 16:55:14 +0100

On Mon, 15 Dec 2014 14:42:44 +0000
Alan Lacerda <alancordeiro_at_gmail.com> wrote:

> ---
> testing/mate-common/APKBUILD | 41 +++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 41 insertions(+)
> create mode 100644 testing/mate-common/APKBUILD
>
> diff --git a/testing/mate-common/APKBUILD b/testing/mate-common/APKBUILD
> new file mode 100644
> index 0000000..f6895da
> --- /dev/null
> +++ b/testing/mate-common/APKBUILD
> _at_@ -0,0 +1,41 @@
> +# Contributor: Alan Lacerda <alacerda_at_alpinelinux.org>
> +# Maintainer:
> +pkgname=mate-common
> +pkgver=1.9.0
> +pkgrel=0
> +pkgdesc="Common scripts and macros"
> +url="http://mate-desktop.org/"
> +arch="noarch"
> +license="CC"

license is gplv3+

> +depends=""
> +depends_dev=""
> +makedepends="autoconf automake gettext"
> +install=""
> +subpackages=""
> +source="http://pub.mate-desktop.org/releases/1.9/$pkgname-$pkgver.tar.xz"
> +
> +_builddir="$srcdir/$pkgname-$pkgver"
> +prepare() {
> + local i
> + cd "$_builddir"
> + for i in $source; do
> + case $i in
> + *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
> + esac
> + done
> +}
> +
> +build() {
> + cd "$_builddir"
> + ./autogen.sh --prefix=/usr || return 1

There is no need to run autogen when the shipped configure works.


I applied and fixed the above mentioned issues.

thanks!

-nc


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Tue Dec 16 2014 - 16:55:14 GMT