Mail archive
alpine-devel

Re: [alpine-devel] openssl-1.0.2 or libressl ?

From: Daniel Cegiełka <daniel.cegielka_at_gmail.com>
Date: Sun, 15 Feb 2015 10:56:25 +0100

Take into account that people from OpenBSD are promoting libtls
instead raw openssl headers. If tomorrow you want to use eg the new
version OpenNTPD, then you will have to use LibreSSL or at least
libtls.

http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/usr.sbin/ntpd/Makefile?rev=1.13&content-type=text/x-cvsweb-markup
http://cvsweb.openbsd.org/cgi-bin/cvsweb/src/usr.sbin/ntpd/constraint.c?rev=1.1&content-type=text/x-cvsweb-markup

http://www.openbsd.org/cgi-bin/man.cgi/OpenBSD-current/man3/tls_accept_socket.3?query=tls_init&sec=3

Daniel


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Sun Feb 15 2015 - 10:56:25 GMT