Mail archive
alpine-devel

Re: [alpine-devel] [PATCH] testing/luufs: new aport

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Mon, 16 Mar 2015 15:17:36 +0100

On Thu, 12 Mar 2015 21:04:11 +0000 (GMT)
ScrumpyJack <scrumpyjack_at_me.com> wrote:

>
> Lazy man's, user-mode union file system
> http://rlsd.dimakrasner.com/
> ---
> testing/luufs/APKBUILD | 39 +++++++++++++++++++++++++++++++++++++++
> 1 file changed, 39 insertions(+)
> create mode 100644 testing/luufs/APKBUILD
>
> diff --git a/testing/luufs/APKBUILD b/testing/luufs/APKBUILD
> new file mode 100644
> index 0000000..ae83f00
> --- /dev/null
> +++ b/testing/luufs/APKBUILD
> _at_@ -0,0 +1,39 @@
> +# Contributor: ScrumpyJack <scrumpyjack_at_me.com>
> +# Maintainer:
> +pkgname=luufs
> +pkgver=05012015
> +pkgrel=0
> +pkgdesc="Lazy man's, user-mode union file system"
> +url="http://rlsd.dimakrasner.com/"
> +arch="all"
> +license="BSD"
> +depends=""
> +depends_dev=""
> +makedepends="fuse-dev zlib-dev"
> +install=""
> +subpackages="$pkgname-doc"
> +source="${pkgname}-${pkgver}.zip::http://dimkr.insomnia247.nl/sources/luufs/luufs-git05012015.zip"

I would have preferred to have $pkgver in $source to make it easier to
upgrade in future (just change pkgver). If this is forgotten when its
upgraded next time, it might end up with new apk with new version
number containing the old (git05012015) version.

applied anyways.

thanks!

-nc


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Mon Mar 16 2015 - 15:17:36 GMT