Mail archive
alpine-devel

Re: [alpine-devel] mpv is broken

From: Isaac Dunham <ibid.ag_at_gmail.com>
Date: Wed, 20 Jan 2016 19:23:37 -0800

On Thu, Jan 21, 2016 at 12:54:32AM -0200, Alba Pompeo wrote:
> mpv is broken on latest release v3.3.1
> (+) Video --vid=1 (*) (h264)
> (+) Audio --aid=1 --alang=und (*) (aac)
> libGL error: failed to open drm device: Permission denied
> libGL error: failed to load driver: i965
> libGL error: unable to load driver: swrast_dri.so
> libGL error: failed to load driver: swrast
> [vo/opengl/x11] X11 error: BadValue (integer parameter out of range
> for operation)
> [vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: 0, serial: 37
> [vo/opengl/x11] Error code: 2, request code: 9a, minor code: 3
> [vo/opengl/x11] X11 error: GLXBadContext
> [vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: a00003, serial: 38
> [vo/opengl/x11] Error code: aa, request code: 9a, minor code: 5
> [vo/opengl/x11] X11 error: 0
> [vo/opengl/x11] Type: 0, display: 0x43f43492980, resourceid: 0, serial: 38
> [vo/opengl/x11] Error code: 0, request code: 9a, minor code: 1a
> [vo/opengl] Could not set GLX context!
>
> I looked on the archives and found a hint, that I should addgroup me
> to video. But I already did that long before and the issue remains.

ls -l /dev/dri/

I suspect that for unknown reasons, eudev isn't setting the proper group.

Currently mdev isn't either...Ah, mdev is only looking for the old
directory-free pathnames (card0 instead of dri/card0).
Adding this to mdev.conf should fix it for those who don't need eudev:
dri/* root:video 0660

There may be a similar oversight in the eudev rules, or there might not.

HTH,
Isaac Dunham


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Wed Jan 20 2016 - 19:23:37 UTC