Mail archive

Re: [alpine-devel] mpv is broken

From: Isaac Dunham <>
Date: Wed, 10 Feb 2016 23:23:45 -0800

On Wed, Feb 10, 2016 at 04:55:21PM +0100, Shiz wrote:
> > On 10 Feb 2016, at 15:36, Alba Pompeo <> wrote:
> >
> > Chromium also have the same error.
> > And I am sure I'm on the video group.
> > libGL error: failed to open drm device: Permission denied
> I’ve been having the same issue with mdev, it somehow failing to set the
> /dev/dri/* permissions properly despite configuration to the opposite.
> Regardless, su -c 'chown -R root:video /dev/dri' fixes the issue, until you reboot.

On my system (uses mdev), this line in mdev.conf solved it:
dri/.* root:video 0660

If you have current busybox-initscripts from edge, this line is in
/etc/mdev.conf as packaged -- or /etc/mdev.conf.apk-new if you've edited
the config file.

If you are using eudev, THIS CANNOT HELP.

eudev uses its own rules, which apparently might have a similar issue
(ie, matching the regex dri/.* should be used instead of moving to dri/).
I am not an expert in (e)udev.

I do not recommend trying mdev-with-X on non-experimental systems.
If you want to try using mdev with X:
- disable X autostarting
- enable mdev, disable eudev
- apk add mdev-like-a-boss-xorg (and xf86-input-synaptics for laptops)
- reboot (so that you use the mdev-prepared /dev, rather than thinking
 it's working because of a stale udev-prepared dir).
- start X
- check that mouse and keyboard work

Isaac Dunham

Received on Wed Feb 10 2016 - 23:23:45 GMT