Mail archive

Re: [alpine-devel] Porting Alpine scripts

From: Tuan M. Hoang <>
Date: Wed, 16 Nov 2016 02:36:39 +0700


I am sorry for a (very) long time break on this topic. Guess this time I
would finally help make Alpine support s390x.

> ---- On Tue, 26 Jul 2016 23:46:54 +0700 Timo Teras
> <> wrote ----
> > b) Then I run crossbuild script, and I need remove paxmark lines
> > in gcc's APKBUILD as it returns an unknown error (while
> > creat-cross script runs just fine). AFAIK, it is about security
> > concerns, not system's functionality, so for now I guess it is
> > okay.
> Your kernel is probably built without XATTR support. paxmark
> requires XATTR enabled kernel.

I guess my x86_64 machine running grsec kernel (linux-grsec package) is
XATTR-enabled. I looked a little bit closer on the build log and see
this : When I try to run those $ paxctl
manually (code from /usr/sbin/paxmark), they just pass alright
with no output on stdout nor stderr. I also tried adding
--enable-xattr-support to configure script in gcc APKBUILD, but it won't
help. What do you think ?

Another problem I am having is when cross-compiling linux-vanilla
package using aports/scripts/ : I
am reading abuild source code to find the cause but still nothing new.
It'd be nice if you help me to have a look.


Received on Wed Nov 16 2016 - 02:36:39 GMT