Re: [alpine-devel] Proposal: testsuite support in APKBUILDs
On Fri, 27 Jan 2017 08:10:19 +0000
Ed Robinson <ed.robinson_at_reevoo.com> wrote:
> I would prefer test over check and (testsuite). Test is a verb so fits
> nicely with the other commands. "make test" is used about 4 times more
> often than make check in the existing packages.
> (634 results) vs
> (180 results)
> I think the idea is a good one overall and I think while naming is
> moderately important, having the feature is more important than
> getting the name right...
'test' is a shell built-in and due to the way abuild is implemented, it
cannot be used. It would break lots of stuff.
I have no strong opinion over 'check' or 'testsuite'.
I'm planning to add 'rootbld' that will do a clean chroot build of the
package. So that would not be strictly a verb either. I have patch for
this, but it's pending a way to configure the repository URLs properly.
Received on Fri Jan 27 2017 - 10:15:02 GMT