Mail archive
alpine-devel

Re: [alpine-devel] Proposal: testsuite support in APKBUILDs

From: 7heo <7heo_at_mail.com>
Date: Fri, 27 Jan 2017 08:55:30 +0000

What about 'tests' or 'runtests'?

But I agree with Ed that getting the feature is much more important than getting the name right.

Theo.

On Fri Jan 27 09:15:02 2017 GMT+0100, Timo Teras wrote:
> On Fri, 27 Jan 2017 08:10:19 +0000
> Ed Robinson <ed.robinson_at_reevoo.com> wrote:
>
> > I would prefer test over check and (testsuite). Test is a verb so fits
> > nicely with the other commands. "make test" is used about 4 times more
> > often than make check in the existing packages.
> > https://github.com/alpinelinux/aports/search?utf8=%E2%9C%93&q=make+test&type=Code
> > (634 results) vs
> > https://github.com/alpinelinux/aports/search?utf8=%E2%9C%93&q=make+check&type=Code
> > (180 results)
> >
> > I think the idea is a good one overall and I think while naming is
> > moderately important, having the feature is more important than
> > getting the name right...
>
> 'test' is a shell built-in and due to the way abuild is implemented, it
> cannot be used. It would break lots of stuff.
>
> I have no strong opinion over 'check' or 'testsuite'.
>
> I'm planning to add 'rootbld' that will do a clean chroot build of the
> package. So that would not be strictly a verb either. I have patch for
> this, but it's pending a way to configure the repository URLs properly.
>
> /Timo
>R{.n+yׯz_˛mbzX+ijZb^~i+-iw{
Received on Fri Jan 27 2017 - 08:55:30 UTC