the 'tests' switch (--tests) is what is used inside quite a number of
packages for their internal building test steps so i wonder if that's
appropriate and even then it may have different purposes. Maybe using it
would get the builder/compiler confused if a problem ocurrs?
The real thing to think about before you give it a name is ?what do you
actually want tested and how is it to proceed in yes|maybe|no
situations. Is it a step in a package build, a step in checking for the
overall release, or something else? Can someone outline what is to go
where in the overall schema and what type of tests are likely to be
actually needed please.
And Leonardo, validate is used internally in some packages for things
like an internal crc of a code area or test against a corrupted or
incorrect source file (usually minor code fixes at the third identity
level being added but not altering the overall package name as it only
uses two levels of version identity externally) so as much as I like it
the best of what's been suggested so far I'm not sure it's appropriate
or available, sorry.
On 01/27/2017 08:45 PM, Leonardo Arena wrote:
> On ven, 2017-01-27 at 08:55 +0000, 7heo wrote:
>> What about 'tests' or 'runtests'?
> Let's throw one more to the mix: "validate" ?
>> But I agree with Ed that getting the feature is much more important
>> than getting the name right.
Received on Sat Jan 28 2017 - 00:22:36 UTC