Mail archive

Re: [alpine-devel] Proposal: testsuite support in APKBUILDs

From: William Pitcock <>
Date: Sun, 29 Jan 2017 02:49:58 -0600


On Fri, Jan 27, 2017 at 1:59 AM, 7heo <> wrote:
> I am really confused that you want to use a wrong vocab because GNU software already use it. Plus, it was my understanding that our tool's name isn't 'make' (since it's about identical terms).

Has very little to do with GNU software, "make check" is #2 most
frequently used in APKBUILD to invoke the testsuite behind "make
test". "test" is a shell built-in and cannot be used, as others have
said in the thread. The reason why "make check" is used so
frequently, is because those packages have an automake-based build

> I understand that for many people this discussion may seems like a waste of time, but using the correct vocabulary is an essential part of code-as-documentation.
> Going with check is not a huge inaccuracy I admit; but it will most likely effectively hinder the understanding of newcomers while lowering the learning curve for GNU people/users.

I'm not really convinced that any new packager will be hindered any
further by that considering that we can explain it in the "how to
write an APKBUILD" guide. We should not make decisions based on
people who do not read docs.

> I can explain in a separate mail (or on IRC) why I think it is a bad enough idea to attract GNU contributors to alpine, to justify continuing this discussion; but I'll assume here that all alpine contributors share a similar view on the GNU code style.

That's not very nice. We should, and do, welcome anyone who wants to
contribute as long as their contributions are in line with the project

> So, does anyone agree?

I agree that some care should be taken to ensure the tests verb is
well known. This is why I chose "check" as an alternative to
"testsuite" (since it is #2 behind "make test" which we can't use).
The most preferable option would be "test" but it's not happening
without a complete rewrite of abuild, which I don't see happening just
to support this...


Received on Sun Jan 29 2017 - 02:49:58 UTC