Mail archive

[alpine-devel] Alpine Linux 3.7.0 Release Candidate 1 on VirtualBox

From: Jack Schmidt <>
Date: Sat, 25 Nov 2017 21:39:02 -0500

Here are my notes on Alpine 3.7.0 rc1 installations using VirtualBox hosted on x86_64 Darwin.


* Standard, Extended, Vanilla, Virtual on BIOS just work (minor issues)
* Standard, Extended, Vanilla on EFI has one major issue (bad fsck)
* Virtual is broken on EFI (no kernel support)

In each case I tried to do a base install to an IDE disk, as "sys", default options. I also tried booting the ISO as a run-from-ram system. Virtual on EFI requires a serial console, but otherwise all ISOs run-from-ram smoothly.

The fsck issue needs to be fixed. The 4.9.63 vs 4.9.59 should be fixed. The Virtual EFI probably should be fixed, but is easily worked-around by end users. The minor issues would be nice to increase adoption of bootable alpine, but aren't necessary. I assume docker containers are just fine: I use edge all the time without trouble.

Standard, Extended, Vanilla, Virtual legacy BIOS minor issues:

* Install boot might be too quiet for too long

The BIOS boot takes 5 to 20 seconds, so the "quiet" option in boot/syslinux/syslinux.cfg might need to be accompanied by a "say" or a "menu autoboot" type thing. Grub EFI boot is mostly better, but sometimes takes a long time between messages. The installed version is a little slow, but has a reasonable amount of messages to let you know it is progressing.

Standard, Extended, Vanilla, Virtual both BIOS and EFI minor issues:

* After setup-alpine is complete, eject cdrom
* Install boot and installed root use different kernels, rescue is hard
* (hardened/virthardened) Guest additions kernel version problem

Install for BIOS works easily on Standard, Extended, Vanilla, Virtual. Install for EFI works easily on Standard, Extended, Vanilla, but fails for Virtual.

After the install, setup-alpine asks to reboot, but doesn't "eject -s" (-s required for me) the cd. That means alpine reboots under the readonly cdrom with a tmpfs. This works fine, but is surprising if you are installing software.

After the eject, system comes up much more noisily / green, so probably reassuring.

However, it comes up under 4.9.59-0-*hardened or 4.9.65 vanilla, so one can't use the ISO's 4.9.63 kernel to boot a rescue. If it isn't too much trouble, for the final 3.7 release, it'd be good if the kernel matched on the ISO's boot and the ISO's apk.

Guest additions (mostly not needed by me) are hard to load, since they are in /lib/modules/4.9.65-* but the kernel is actually 4.9.59-*. Once that is fixed, all good.

Standard, Extended, Vanilla EFI issue (vfat.fsck)

* 1.5GB disk required
* vfat.fsck

Alpine is known for it's very small size. The ISOs are a nice size. I have a VM that runs off a 10MB iso, and the Virtual ISO is good at under 40MB. I was trying out ubuntu variations and had to choose my physical network to handle the each-iso-is-a-gig downloads. Alpine is very easy to try. However, the new EFI install creates a 500MB /boot/efi partition to hold 500KB of boot data. It might be worthwhile to check the total size of the disk, and not use so much on it for smaller (1 or 2 gig) drives.

More importantly /boot/efi fails its fsck due to a syntax error:

fsck.vfat: unrecognized option: C

This is from /etc/init.d/fsck. Since the fsck service fails, most of the rest of the boot is not really attempted. / is mounted read-only. Network is down.

Remounting / rw, removing the -C0 from fsck, and rebooting is OK. You still get a scary error, but the system comes up fine.

See also for raspberry pi breakage and suggested fix (seems reasonable to me: write a simple shell script wrapper for fsck.vfat and fsck.fat that ignores ext2/3/4 arguments).

I think this must be fixed before a release.

Virtual EFI fail

Virtual's virthardened kernel lacks EFI support (even in module form). Also it is worse on VirtualBox EFI since it also lacks video drivers. The serial console works, but is hard to use (telnet lacks tab-completion, GNU screen requires socat, and only one terminal). Since /sys/firmware/efi is not available, setup-disk does not realize it was an EFI boot and does everything wrong.

I suspect it would be a good idea to include EFI support for the Virtual ISO / virthardened kernel too. The fix would make Alpine seem more reliable and would cut down on the "why is the screen black?" questions. However, to workaround it is easy to turn off EFI, and legacy BIOS is more standard for virtual machines, I believe.

Received on Sat Nov 25 2017 - 21:39:02 GMT