Mail archive
alpine-devel

Re: [alpine-devel] apk fetch --recursive broken in >= v3.7

From: Timo Teras <timo.teras_at_iki.fi>
Date: Tue, 5 Dec 2017 18:20:44 +0200

On Sun, 3 Dec 2017 17:43:14 +0100
Roger Newman <roger.newman_at_riseup.net> wrote:

> currently I am not able to fetch some packages with there
> dependencies. Same packages on v3.6 did not have any of this issues.

It's because shell dependencies where changes from 'busybox' to virtual
'/bin/sh' dependency, and apk expects one to tell which shell to use.
Add 'busybox' to the list of packages and it should work.

apk is getting better error messages for 'fetch' in future.

Timo



---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Tue Dec 05 2017 - 18:20:44 GMT