Mail archive
alpine-devel

Re: [alpine-devel] Huh? Error reporter did not find the broken constraints.

From: William Pitcock <nenolod_at_dereferenced.org>
Date: Mon, 1 Jan 2018 22:49:07 -0600

Hello,

On Mon, Jan 1, 2018 at 8:26 PM, William Pitcock
<nenolod_at_dereferenced.org> wrote:
> Hello,
>
> On Mon, Jan 1, 2018 at 7:19 PM, Oliver Smith
> <ollieparanoid_at_bitmessage.ch> wrote:
>> Sorry for not reporting it yet.
>>
>> In our case the bug was triggered by a "dbus-nox11" package we created - probably because it ended up providing the same "so:..." dependency as the official "dbus" package. It worked fine, and at some point (maybe after an apk upgrade?) the package didn't work anymore - after we removed it, it worked again.
>>
>> If it helps with debugging/fixing this issue, I could try to reproduce the way the bug affected us, and provide apk's installed DB.
>
> I think I can create a reproducer. I will do it after I finish cooking dinner.

Unfortunately based on this data, I was unable to create a testcase.

Adding two packages resulted in an unsatisfiable constraints problem,
but it explained what the problem was (that it wanted the user to
choose a provider).
I did add those testcases to apk-tools git if you would like to look at them...

Could somebody reproduce the failure with apk-tools git compiled with
debug printing enabled?

Thanks in advance!

William


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Mon Jan 01 2018 - 22:49:07 GMT