Mail archive
alpine-devel

[alpine-devel] PHP5 EOL

From: Andy Postnikov <apostnikov_at_gmail.com>
Date: Tue, 21 Aug 2018 15:13:35 +0300

Hi there!

I'd like to get opinions on a way how to get rid of php5 & related packages
from edge & 3.9

On 31 Dec 2018 php5 goes EOL https://secure.php.net/supported-versions.php
it means no more security updates will be available

In edge there are 3 packages - php5, php5-apcu & php5-suhosin (all in
community)
Also there's 5 packages that depends on php5 - cacti-php5,
phoronix-test-suite, phpldapadmin, rutorrent, zoneminder

I suggest to get rid of php5 packages, fix dependent ones as first step,
filed https://bugs.alpinelinux.org/issues/9291 to track changes

Then makes sense to rename all php7 packages to get rid of *7* suffix.

Also it makes sense to normalize package names for the rest of php
extensions be splitting PECL-based and others. Filed
https://bugs.alpinelinux.org/issues/9277 to track this

-- 
*Andy Postnikov*, drupal consultant
dgo.to/_at_andypost
skype:andypost2005
---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Tue Aug 21 2018 - 15:13:35 GMT