Mail archive
alpine-devel

Re: [alpine-devel] efivar,efibootmgr: stabilization on all architectures

From: Gennady Feldman <gena01_at_gmail.com>
Date: Thu, 6 Dec 2018 12:53:43 -0500

I know it's been almost a year since this thread. Was trying to see if efi
setup was stable/working since last time I tried it. I tend to run Alpine
inside a VM. so I pulled the latest 3.8.1 Sep 11 Virt iso and tried to boot
inside VirtualBox with EFI enabled. I got the grub menu with "virt" kernel
option. After that it tried to boot the kernel and then nothing happened
after that. I think there was some effort to get the efi modules into the
virt kernel.

P.S. As a side note tried booting Alpine insider Hyper-V using "generation
1" (no EFI) and Linux "virt" kernel managed to enable hyperv_fb framebuufer
which was a pleasant surprise.

On Fri, Jan 26, 2018 at 4:11 AM Carlo Landmeter <clandmeter_at_gmail.com>
wrote:

> On 24 January 2018 at 01:36, Michael Davies <nemykal_at_nrv-linux.io> wrote:
> > Hi,
> >
> > I have an aarch64 system that uses UEFI that I can test with. My
> experience with EFI on arm is that it’s even more fickle than on x86, so if
> possible it would be good to test on several platforms. This system is a
> gigabyte mt30-gs0 board with a cavium thunderx chip. I’ll test out alpine
> on it this weekend.
>
> Our aarch64 port is using the same board "mt30-gs0" booted with uefi
> so i can confirm it works.
>
> -carlo
>
>
> ---
> Unsubscribe: alpine-devel+unsubscribe_at_lists.alpinelinux.org
> Help: alpine-devel+help_at_lists.alpinelinux.org
> ---
>
>



---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Thu Dec 06 2018 - 12:53:43 UTC