Mail archive
alpine-devel

Re: [alpine-devel] Re: openrc crashes

From: Steffen Nurpmeso <steffen_at_sdaoden.eu>
Date: Thu, 03 Jan 2019 21:38:14 +0100

Steffen Nurpmeso wrote in <20181231181115.X9XVy%steffen_at_sdaoden.eu>:
 |Phil Hofer wrote in <F9zS9AxnlZczhqhPenmGcQsk5Kbp-FOF-1hFiyUW2Phwc4FbTe-\
 |mtNPr9KVaC8LBT2AochKodG2j5RxEO14BJAmrjxe6jR5nNcQ6FkMc__U=_at_sunfi.sh>:
 ||I ran into some crashes in openrc recently as well.
 ||(Once I ran my reproducer in gdb, I saw that openrc was tripping
 ||the stack-smashing protector.)
 ||
 ||I went through the source and made some reliability fixes,
 ||which have now been committed upstream:
 ||
 ||846e46 -- fix 4 out-of-bounds reads
 ||084877 -- fix stack buffer overrun (my issue)
 ||a9fc26 -- fix NULL dereference
 |
 |I see. Good to know someone cared for crashes there!
 |
 ||Try building the latest version of openrc and see
 ||if your issues persist. (You'll have to take some patches

I have not done that, but as it happened again today after
i manually have changed the runlevel, i saw that OpenRC seems to
falsely unroll the hierarchy, at least from looking at the
messages!

I have default->net->wlan->wlan-up, the latter only with ntp
running, and once i switched from wlan-up->default, all services
from wlan where shut down before the ntp of wlan-up.
I do not know how this could cause the problems, but the
behaviour seems very wrong to me.
What do you think, should i open an AlpineLinux bug??
(I have not github account, which is why i am asking.)

Ciao, Phil,

--steffen
|
|Der Kragenbaer, The moon bear,
|der holt sich munter he cheerfully and one by one
|einen nach dem anderen runter wa.ks himself off
|(By Robert Gernhardt)


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Thu Jan 03 2019 - 21:38:14 UTC