Mail archive
alpine-devel

Re: [alpine-devel] Re: Adding Local Abuild Package to Cache

From: Carl Chave <online_at_chave.us>
Date: Mon, 18 Mar 2019 07:25:57 -0400

> You can also add your public key from /etc/apk/keys in your dev environment to /etc/apk/keys on the remote host so your custom packages are trusted.
>
> Stuart.
>
>
Thanks Stuart, yes, I had the dev public key in /etc/apk/keys on the
same host as the abuild environment - I only have one raspberry pi 3
B+, my other pi's are armhf. To perhaps muddy the water a bit more,
the pi 3 I used as the dev host was already loaded with 3.8.2 armhf
and I had /home on a separate ext4 partition. I setup the abuild
environment, built the packages, and tried to test but ran into the
cache issue I described above. As part of the troubleshooting I
decided to wipe the OS partition and load 3.9.2 which is when I
discovered that support for the pi 3 B+ has apparently been dropped
from the armhf build and so I moved to the armv7 build but still
mounted old /home directory with the existing aports and packages
directories.

I did various other things after that, cleaned out keys and previously
built packages and generated new keys and rebuilt the packages,
removed the old pubic key from /etc/apk/keys and put the new key in -
I think at the end I had a correct armv7 abuild environment but I had
the same problem trying to get the packages to stick on reboot when
installing from the local repo. Since I still had the previously
built armv6 packages, I scp'd those over to a raspberry pi zero w and
installed with --allow-untrusted and that worked, I guess it was late
in the day but I didn't think to add the pi 3's repo to the pi zero
and install that way rather than scp'ing and installing as local
untrusted packages. I will try that just as another data point.

Carl


---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Mon Mar 18 2019 - 07:25:57 UTC