Mail archive
alpine-devel

Re: [alpine-devel] Should we drop armhf (armv6) support with 3.10 release?

From: Oliver Smith <ollieparanoid_at_bitmessage.ch>
Date: Thu, 04 Apr 2019 17:02:00 +0000

Hello Natanael,

I would strongly prefer if we don't drop armhf on such short notice. As
you know, postmarketOS uses Alpine's repositories (with some extra
packages on top). We have device specific packages for each phone /
other target device, and right now there are only 16 armv7 devices
compared to 80 armhf devices.

If we have to drop armhf any time soon (which is understandable
considering the resources you have mentioned), then I would suggest to
do it in 3.11 and explicitly mention it in the 3.10 release notes.

Thanks,
Oliver

Natanael Copa:
> Hi,
>
> I wonder if can drop armhf (armv6) support with the 3.10 release, now
> that we have armv7?
>
> In practice it means that we no longer support Raspberry PI 1 and Zero.
>
> We will still support those with alpine v3.9 for another year.
>
> I believe dropping armhf (armv6) will save some resources when it comes
> to managing build servers, disk space, spending time on fixing armhf
> specific problems.
>
> We may also optimize the vanilla kernel better for armv7, which
> currently uses same config as armv6.
>
> What do you think, can we drop armhf for v3.10 or should we wait til
> v3.11?
>
> -nc
>
>
> ---
> Unsubscribe: alpine-devel+unsubscribe_at_lists.alpinelinux.org
> Help: alpine-devel+help_at_lists.alpinelinux.org
> ---
>
>



---
Unsubscribe:  alpine-devel+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-devel+help_at_lists.alpinelinux.org
---
Received on Thu Apr 04 2019 - 17:02:00 UTC