Mail archive
alpine-infra

Re: build-edge-s390x is broken, needs abuild upgrade

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Mon, 2 Oct 2017 10:18:20 +0200

On Sat, 30 Sep 2017 16:25:00 +0200
Jakub Jirutka <jakub_at_jirutka.cz> wrote:

> Hi,
>
> s390x is broken due to running outdated abuild. Please someone who
> has access to the builder upgrade abuild package to 3.0.2.
>
> Jakub

I have fixed this now.

When we implement new features in apk-tools and abuild that are not
backwards compatible, we should preferable not use those til after next
stable release. This is to prevent issues like this, but also to make
maintenance easier, because otherwise you need to watch out for
incompatible changes when you backport to stable branch. You will also
prevent problems when mixing last stable with edge repo.

This is important especially for apk-tools, but also for abuild.

So in this case, where abuild got new feature of automatically
splitting -openrc subpackages, we should have waited with using this in
any APKBUILD til after 3.7 is release and things would gone much
smoother.

Thanks!

-nc
Received on Mon Oct 02 2017 - 10:18:20 GMT