Mail archive
alpine-user

Re: [alpine-user] apk-install behind proxy

From: Jeff Bilyk <jbilyk_at_gmail.com>
Date: Thu, 12 Mar 2015 10:09:40 -0400

Yes, it respects http_proxy.

On Thu, Mar 12, 2015 at 9:58 AM, Manuel Holzleitner <
manuel.holzleitner_at_gmail.com> wrote:

> Hello,
>
> I would like to know if the apk-tools (i.e. apk-install) respect the
> http_proxy/https_proxy environment variables?
>
> I get the following error:
> fetch http://dl-4.alpinelinux.org/alpine/v3.1/main/x86_64/APKINDEX.tar.gz
> ERROR: http://dl-4.alpinelinux.org/alpine/v3.1/main: IO ERROR
> WARNING: Ignoring APKINDEX.689bb31a.tar.gz: No such file or directory
>
> This looks like the http request is not issues through the proxy, even
> though the environment variables are configured. A "wget www.google.com"
> on the other hand, works just fine by connecting to through the proxy as
> expected.
>
> In case the apk-tools do not respect these environment variables, is there
> any other way to configure proxy settings?
>
> Kind Regards,
> Manuel
>



-- 
Jeff
---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Thu Mar 12 2015 - 10:09:40 GMT