Mail archive
alpine-user

[alpine-user] alpinelinux 3.3.1 can not boot, when root is on lvm, which is on raid1

From: Dieter Bloms <alpinelinux.org_at_bloms.de>
Date: Fri, 8 Jan 2016 21:56:34 +0100

Hi,

I installed alpinelinux 3.3.1 with manual disc mode.
My root is a logical volume in a volume group on a raid1 system.
During boot the raid is activated, but the logical volumes are not.
So I have to activate it manually and mount it to /sysroot.
After that I can boot into alpinelinux.

Is it a known problem, that lvm on a raid is not activated in the
initramfs during boot ?

My /boot is on a usbstick and sdc is a backup disc.

Here some data from my setup:

--snip--
docker:~# lsscsi
[0:0:0:0] disk ATA ST4000VN000-1H41 SC44 /dev/sda
[1:0:0:0] disk ATA ST4000VN000-1H41 SC43 /dev/sdb
[3:0:0:0] disk ATA Hitachi HDS72202 A3MA /dev/sdc
[6:0:0:0] disk Generic Flash Disk 8.07 /dev/sdd

docker:~# cat /proc/mdstat
Personalities : [raid1]
md1 : active raid1 sdb1[2] sda1[0]
      3906886464 blocks super 1.2 [2/2] [UU]
      bitmap: 2/30 pages [8KB], 65536KB chunk

unused devices: <none>

docker:~# pvs
  PV VG Fmt Attr PSize PFree
  /dev/md1 space lvm2 a-- 3.64t 293.89g
  /dev/sdc1 backup lvm2 a-- 1.82t 0

docker:~# lvdisplay /dev/space/alpine
  --- Logical volume ---
  LV Path /dev/space/alpine
  LV Name alpine
  VG Name space
  LV UUID RU7k0a-NTdS-MUiG-tI1K-79Ub-66OQ-HwGQ0T
  LV Write Access read/write
  LV Creation host, time docker, 2015-12-28 15:37:56 +0100
  LV Status available
  # open 1
  LV Size 2.00 GiB
  Current LE 512
  Segments 1
  Allocation inherit
  Read ahead sectors auto
  - currently set to 256
  Block device 253:16

docker:~# blkid /dev/space/alpine
/dev/space/alpine: UUID="1158e9c8-5e60-4318-99ef-67b617ef0f17" TYPE="xfs"

docker:~# cat /proc/cmdline
BOOT_IMAGE=vmlinuz-grsec root=UUID=1158e9c8-5e60-4318-99ef-67b617ef0f17 modules=loop,sd-mod,usb-storage,raid,lvm,xfs quiet initrd=initramfs-grsec

docker:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
devtmpfs 10240 0 10240 0% /dev
shm 4059628 0 4059628 0% /dev/shm
/dev/space/alpine 2086912 603096 1483816 29% /
tmpfs 811928 328 811600 1% /run
cgroup_root 10240 0 10240 0% /sys/fs/cgroup
/dev/sdd2 999320 26288 904220 3% /boot

docker:~# cat /etc/mkinitfs/mkinitfs.conf
features="ata base ide scsi usb raid lvm xfs"


Can anybody see where I did a mistake ?

-- 
Regards
  Dieter
--
I do not get viruses because I do not use MS software.
If you use Outlook then please do not put my email address in your
address-book so that WHEN you get a virus it won't use my address in the
From field.
---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Fri Jan 08 2016 - 21:56:34 GMT